美文网首页
数据结构实验之查找一:二叉排序树

数据结构实验之查找一:二叉排序树

作者: Otis4631 | 来源:发表于2017-11-18 14:04 被阅读0次

数据结构实验之查找一:二叉排序树

Time Limit: 400MS

Memory Limit: 65536KB

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

<font style="box-sizing: border-box;" face="">输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。</font>
<font style="box-sizing: border-box;" face="">简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。</font>

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Example Input

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

Example Output

Yes
No
No

Hint

/*-------------------------
Name:数据结构实验之查找一:二叉排序树
Author:Mr.z
Time:2016-12-7
---------------------------*/
#include <iostream>
#include <stdlib.h>
using namespace std;
typedef struct BiTnode{
    int data;
    struct BiTnode *lchild,*rchild;
};
bool Judge(BiTnode *root1,BiTnode *root2){
    if(root1==NULL && root2==NULL)
        return 1;
    else if(root1!=NULL && root2!=NULL)
    {
        if(Judge(root1->lchild,root2->lchild) && Judge(root1->rchild,root2->rchild))
            return 1;
        else
            return 0;   
    }
    else return 0;
}
 BiTnode *Insert(BiTnode *root,int key){
    if(!root){
        root=(BiTnode *)malloc(sizeof(BiTnode));
        root->data=key;
        root->lchild=root->rchild=NULL;
    }
    else{
        if(root->data>key)
            root->lchild=Insert(root->lchild,key);
        else 
            root->rchild=Insert(root->rchild,key);
    }
    return root;
}
BiTnode *createBST(int n){
    int temp;
    BiTnode *root;
    root=NULL;
    for(int i=0;i<n;i++){
        cin >> temp;
        root = Insert(root,temp);
    }
    return root;
}
int main(){
    int n,m;
    while(cin >> n >> m && n){
        BiTnode *root;
        root=createBST(n);
        for(int i=0;i<m;i++){
            BiTnode *root0;
            root0=createBST(n);
            if(Judge(root,root0))
                cout << "Yes\n";
            else cout << "No\n";
        }
    }
    return 0;
}

/***************************************************
User name: zhxw150244李政
Result: Accepted
Take time: 0ms
Take Memory: 160KB
Submit time: 2016-12-07 18:21:45
****************************************************/

相关文章

网友评论

      本文标题:数据结构实验之查找一:二叉排序树

      本文链接:https://www.haomeiwen.com/subject/mnpevxtx.html